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Improved Movement Manual Straightening

You know how to make the robot move, and you've made improvements to its performance by
having it brake and maneuver at a slower speed. Even so, you have probably noticed by now that
the robot’s idea of “straight”... isn't.

Off course
This robot has drifted noticeably
to the left while running.

{

Even when you set the motors to go the same speed, the robot turns a little. Recall that a turn
results from two motors moving at different speeds.

1 task main ()
2 |
3
4 motor [motorC] s 4
5 motor [motorB] If(l’;gf?\ fnp:igrs.are set the same,
6 waltlMsec (4000) ; shouldn’t they go the same speed
7 and therefore move straight?
8 motor [motorC] = -50;
9 motor [motorB] = 50;
10 waitlMsec (800) ;

11
12 }

Actually, SPEEDS aren’t set with the motor[] commands. Motor POWER is. However, not all motors
are created equal. Various factors in the robot’s construction, and the manufacturing process for
the motors themselves cause different amounts of energy to be lost to friction in each motor.

This means that even though both motors start with the same power at the plug, the amount of
power that reaches the wheel to move the robot can vary quite a bit. Even with the same POWER
being applied, SPEEDS may differ. And as you know, wheels moving at different speeds make the
robot turn, even if just a little bit. So to fix this situation, let’s do the logical thing, we'll change the
power so the motors end up going the same speed.

. /
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Improved Movement manual Straightening (cont.)

In this lesson, you will manually adjust your motor command powers to make your robot go
straight, watching for patterns to make the process smoother in the future.

Lesson Note

The example robot used in this lesson
drifts slightly to the left. If your robot
drifts in the other direction, simply apply
the following steps to the other motor.

e
=

—_—
Y \ .=

1. We can't speed up the slower motor, because it's already going full power. So instead, we'll
have to slow down the faster one. The robot shown in this example has veered left, indicating
that the right motor is going faster than the left.

1 task main()
2
> dify th d
_ - 1a. Modify this code

4 motor[motorC] = oP; Reduce the faster motor’s power by 5%
5 motor [motorB] =(45; in the moving-forward behavior.

File Edit Wiew Window _Help

O 1b. Compile and Download

ECampile Frogranm SelecT Rob01 > Compile cnd
Download Program.

Battery & Pow
1  Construcks Diebugger
Display
1 Motars MET Brick o

2400

1 gzz:?:lrs Platfarm Type 4 g]D atus Fiefresh Rate
Timing Motors and Sensars Setup ) — [ _—_ 1. [ | 1c. Press Start
User Defined | Download Firmware Sto Press the Start button on the
Clear &ll | Clear Log Program Debug menu.

1 =

1d. Observe behavior
Did the robot go straight?
This one curves to the right now.

N
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Improved Movement Manuadl Straightening (cont)
2. We seem to have overcorrected, and our robot now curves in the opposite direction. So we'll
adjust our guess, and go with something in between the original and our last guess.
1 task main()
2
3 2a. Modify this code
4 motor [motorC] = 50 was too high, and 45 too low.
Choose a value in between, like 48.
5 motor [motorB] =
&) waitlMsec (4000) ;
File Edit View Window  Help
O 2b. Compile and Download
1 Batfory & poy,  ECOMDIE ProGTam Select Robot > Compile and
 Constructs Diebugger Download Progrom.
1 Display
1 Maokars MAT Brick 3
SBHSDdFS Flatform Type » Refresh H2;t20
?ion:::g Motors and Sensors Setup i — Iul ] 2c¢. Press Start
User Defined | Dowrload Fi - Press the Start button on the
D:'moa :Irmware Program Debug menu.
2d. Observe behavior
Did the robot go straight?
It looks a lot better now.
End of Section
This method of manual straightening works, but it's unwieldy. One big problem is that it
requires reprogramming any time something changes. Running on a different table surface,
negotiating a slope, running after the batteries have run down, and even tuning up the robot
will all force you to re-adjust these values.
Worse still, the program values don’t work on every robot. In the example, we had to change
our motor to 48%, but you probably had to do something quite different with yours. Worse
yet, there are obstacles out there that can’t be accounted for by programming your robot
hours or weeks in advance. Manual adjustment to robot power levels can work, but there
must be a better way...
- /
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Improved Movement Principles of PID

We found that we could make a robot move straighter by adjusting power levels so that its
wheels move at the same SPEED rather than just being driven with the same power. However,
manual adjustment has severe limitations. What if we could find a way to make those
adjustments automatically?

In this lesson, you will learn how the PID speed control algorithm works.

Using the rotation sensors built into the NXT motors, the robot can be aware of how far each
wheel has moved. By comparing the motor’s current position to its position a split second ago,
the robot can calculate how fast the wheel is moving.

Current
Position

Starting position (1=0) A short time later... (1=0.1s)

The initial position of the wheel as it starts turning. 1/10th of a second later, the wheel has turned slightly.
Since both the change in position and the change in time
are known, the robot can calculate the rate of turn.

Suppose the wheel turned 30 degrees in the 0.1 seconds shown above. The robot would
automatically calculate the speed as:

—» Speed = 30°

= Atime Oisec " Speed = 300°/sec

This speed is translated into a “speed rating” in the NXT firmware so that a speed rating of 100
would correspond to an “ideal motor” running at 100% power.

Since the robot can now tell how fast the wheel is actualy turning, it can use PID to tune the
motor power levels to make sure it is running at the correct speed. If the motor’s actual speed
is lower than it should be, the PID algorithm will increase its power level. If the motor is ahead,
PID will slow it down. On the following page, we'll find out how it works.

/
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Improved Movement Principles of PID (cont)

Desired Motor
Speed ' Power

1. Motor Power

The motor is told to run at a power level that will theoretically

produce the correct speed.

Without PID control, this is the only step used.

Without PID engaged, motor control is an “open loop” process. Motor power is set, but no

mechanism is in place to see whether the desired speed is actually being acheived, and no

corrections can be made.

Desired Motor Measured
Speed ' Power ' Speed

2. Measured Speed

With PID, the robot will also measure the actual speed of the motor, by

measuring the position of the wheel over time (as shown on the previous page).

Real motors very rarely match up perfectly with “ideal” values, therefore the actual speed is

different when given the “theorotical” power.
. /

© Carnegie Mellon Robotics Academy / For use with LEGO® MINDSTORMS® Education NXT software and base set 9797

Improved Movement © 5



] ROBOTC
\
ovementi
\ S
4 N
Improved Movement Principles of PID (cont)
Desired Motor Measured
Speed ' Power ' Speed
3. Error
The difference between the desired speed and the actual speed Error
is calculated. This difference is called the “error”. A large error
indicates that the motor’s actual speed is significantly different
from the speed it should be maintaining.
How far off is the speed? The “error” term is simply the difference between the
measured speed and the desired speed.
Desired Motor Measured
Speed ' Power ' Speed
4. PID Adjustment
Based on the size of the error,
the PID algorithm proposes an . PID Error
adjustment to the motor power that Adlusi‘meni‘
should get the motor’s actual speed
closer to the desired speed. + 5 4
Based on the size of the error term, and how the error has been changing over
time (has it been getting bigger or smaller?), the PID algorithm calculates an
adjustment to the motor power that should help the motor’s actual speed to get
closer to the desired speed.
\_ %
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Improved Movement Principles of PID (cont)
Desired Motor Measured
Speed ' Power ' Speed

5. Apply Adjustment

The PID Adjustement factor is PID Error

applied to the robot’s motor o

power (50 + 5 = 55). Adjustment «

The new motor power is calculated by adding the PID adjustment factor to the original power.
Desired Motor Measured
Speed ' Power ' Speed

6. Repeat Cycle

The motor runs with the new

power, and the cycle repeats. . PID Error

The robot measures the new Ad|usimeni

speed, calculates a new error,

and a new adjustment. This

process of self-adjustment 2 3

continues as long as the + -

program keeps running.

The adjustment is applied to the motor power. The speed is measured again. The error is

recalculated (hopefully it is now smaller!). A new adjustment factor is determined. The cycle

continues forever, always ready to catch and compensate for any factor that may make the

robot go at the wrong speed.

- /
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Improved Movement Principles of PID (cont)

End of Section

This setup, where the robot monitors and adjusts its speed based on measurements it takes
itself, is called “closed loop” control. The term refers to the “loop” relationship formed by
output (motor power) and feedback (speed measurement, error, and PID adjustment factor).

PID gives your robot the ability to intelligently self-adjust its motor power levels to the correct
values to maintain a desired speed. The closed-loop system monitors the “error” difference
between how fast the robot is going and how fast it should be, and makes adjustments to the
motor’s power level accordingly.

/
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Improved Movement pip Programming

ROBOTC includes a PID algorithm already built into the firmware. In order to take advantage of
PID speed control, you must first enable it in your program.

In this lesson, you will learn how to enable PID speed control for your robot’s motors, using
ROBOTC'’s built-in motor control features.

-
.

Start with your moving-and-turning Labyrinth program. Save your program with a new
name: “LabyrinthPID".

RobotC - Labyrinth.c *
Views Robob  \Window Help
Chrl+M ‘1?

Ta. Save program As...
Select File > Save As... to save your
program under a new name.

Openjand Compile

T maini)
Open|Sample Program

Ctrl+-3

tor [motorC] =50;
tor[motorBl =50: ,b. Browse to an

Print... CHpFF

Prinkt Preview ritiliseci2000) appropriate folder

Pag| Browse to or create an appropriately
. named folder within your program

Savein(| 3 programs ) v OF e m- folder to save your program.

___2_ ri:] Labwyrinth. c
My Recent
Documents
(4
D
Tc. Rename program
Give this program the
new name “LabyrinthPID”.
File name: ( LabwrinthPID] ) hd | ([ Save 1d. Save
Save as type: C Files [*.rec”.c.cpp nge:.h:".ngh) v | [ Cancel Click Save.
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Improved Movement PID Programming (cont)
2. PID control must be enabled for each motor on the robot.
1 task main ()
B 2a. Add this code
3 | Enable PID control on both
_ . motors by setting their
4 nMotorPIDSpeedCtrl [motorC] = mtrSpeedReg; nMotorPIDSpeedControl
5 nMotorPIDSpeedCtrl [motorB] = mtrSpeedReg; modes to mtrSpeedReg.
6
7 OGRS [PIEGEC]) = 2b. Modify this code
8 motor [motorB Restore the motor command
9 waitlMsec settings to 50%.
10 2c. Modify this code
11 motor [motorC] = -50; We want enough time
12 motor [motorB] = 50; fo see and fest the
. effects of PID control.
13 walitlMsec (800) ; Change this value to 30
14 seconds (30000 ms).
15 }
3. Download and run. Keep your robot plugged in.
3a. Block up the robot
Place an object under the robot so that
its wheels can’t reach the table. This
lets you run the robot without having
to chase it around.
OE Cormpile : 3b. Download and Compile
Battery .pon  RECOMPIE Program Click Robot > Download Program.
C Constructs Debugger
Display
Mokors KT Brick ¥ beedCtril[motorC] = mtrSpd
Sensors Platform T N eedltrl[motorB] = mtri3pdg
Sound e
Timing Motors and Sensors Setup Program Debug
Dowrload Firmware 2400
Fefresh Rate
_ : {Slepnle) Luce 3c. Run the program
Click “Start” on the onscreen
St
Dlear Log Program Debug window.
N %
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Improved Movement PID Programming (cont)
4. A window should appear called the “NXT Device Control Display”. If it doesn’t appear...
[:2: Read Walues frorm MNXT
totor] Speed]  PID] Mode [ Fegulate [Run State] Tach User]Tach Move] Tach
bt S 0 0| OFF[Float] 0 fhiore |dle i] ]
bt B 0 0 OFF[Float) 0 nione Idle 0 0 o .
) e : : ——— 4. NXT Device Control Display
i = . A L i i Make sure this window is showing. If nof,
open it through Robot > Debug Windows >
NXT Devices.
0= n Compile and Download Program FS
Battery & For Recompile Pragramm F7
 Constructs Debugger
Display Global Yariables
Mokors Wt 3 py
Sound .
Timing Flatform Type 3 pp—
Lser Defined Motars and Sensars Setup B]=50:
Ly load Ei Qo :
Checkpoint
This debugger window is a troubleshooting tool that can help you see what your robot is doing,
and what it thinks it’s doing. The lines we're interested in are highlighted above: “Speed” and
“PID" for Motors C and B.
The Speed column shows the desired speed for the motor, which we set to be 50%. The PID
column shows the actual amount of power that the robot is giving the motor to make it move at
that speed.
MXT Device Control Display
Fead Values from BT
Adjusted motor power
M ator 5peed| F'ID| M ade | Regulate | Fun The PID algorithm is having to give
this motor 64% power to achieve
A L 0 OFF(Float] 0 Mone ! 50% speed. This is typical, because
B 50 Ed)DN[E[EIkE, Reg]  Speed  Ru the motor needs additional power to
C A0 67 OM[Brake, Reql Speed | Ru overcome friction.
\_ %
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Improved Movement PID Programming (cont)

5. Hold one wheel in place and watch the power values on its corresponding motor.

5a. Hold wheel

Grab one of the wheels on the robot
and hold it so it stops. In the picture,
motor C’s wheel is being held.

MNXT Device Control Display

Read “alues from BT

5b. Observe motor power

b otor 5|:1E:E.-d| F'|D| kMode | Requlate | Run The PID clgorifhrrc; will n(j)ﬂc? tIlet the
motor’s measured speed is falling
A 0 0 DFF[F|DEI|:] 0 none | behind where it should be, and will
B ] ES OM[Brake. Reql Speed | Ru increase the motor’s power level fo try
50 100 DM(Brake, Fegl  Spesd | Fu to bring the speed up.

|D~E'.|"l nrlTur.E |h.-:|_|:|,|:|,e [ "u"a]uel F!ad

6. Release the wheel and observe its reaction.

6a. Release the wheel
Let go of the wheel so it can turn

freely again.
MNXT Device Conktrol Display
Fead Yalues froum BT 6b. Observe motor power
Now that the wheel is going too fast,

b ik cr Speed| F'|D| M ode | Fegulate | Rt ?he motor will decrease its power until
2 0 0 OFF(Float] 0 — | it reaches the correct speed.
B Al B2 OM[Brake, Reg] Speed | Ru
C ] 35 OM[Brake, Reg)  Speed | Hu

|E:E'.|"l nrlTur.E |h.-:|_|:|,|:|,e [ "u"a]uel F!ad

- /
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Improved Movement PID Programming (cont)

7. End the program and return the timing to what it was before.

1 task main ()

2 {

8

4 nMotorPIDSpeedCtrl [motorC] = mtrSpeedReg;

5 nMotorPIDSpeedCtrl [motorB] = mtrSpeedReg;

6

7 motor [motorC] = 50;

8 motor [motorB] = 50;

1 3 vattitisec (:4 el é-hlrn(;‘i,g;’:i:;iz;‘{)eock to
4000m:s (still at 50% speed).

11 motor [motorC] = -50;

12 motor [motorB] = 50;

13 walitlMsec (800) ;

14

15 }

End of Section

PID control is a great way to make your robot’s movement more consistent. The algorithm
monitors how fast the motors are turning versus how far they should be, and adjusts the motors’
power levels to keep them on track. This allows the robot to automatically adjust for minor
variations both in the environment and in the motors themselves.

. /
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Improved Movement Synchronized Motors

When we started, we said that we wanted the robot to go straight. Its motors should move at the
same speed. PID control gave us that in a roundabout way: by asking both motors to maintain
a target speed, and giving them both the same target, they moved the same speed. Sort of.

If we run into a tough spot like this, how should the robot react?

Stuck

The wheel is being held firmly
in place... what should the
other wheel do?

Using PID, the other motor will keep running at the speed it was set to, and the robot will begin
to spin in a circle as if ordered to turn.

However, if going straight is the priority, then we need to change our perspective slightly. We'll
need to enforce identical speeds on the two motors as our first priority, not just tell both motors
to seek the same target independently. The sameness of the values is more important than
the exact speed.

ROBOTC includes a feature called Motor Synchronization, which allows you to pair two motors
together, and define their speeds relative to each other. If you tell them that their goal is to stay
exactly together with one another as they move, then they will, even if it means the faster one
has to stop and wait. The goal of keeping both motors together takes precedence over reaching
the “ideal” speed.

. /
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Improved Movement synchronized Motors (cont)

In this lesson, you will learn how to use Motor Synchronization to ensure that both motors run
at the same speed, even if something unexpected happens to one of them.

1. Open ROBOTC and start a new program.

Edit Wiew Robot Window Help

1. Create new program
Compile Select File > New to create a

Open Sample Program blank new program.

Save Cirl+S

Save As..,

Brint... Cirl+P
Print Preyiew
Page Setup...
Print Setup...

2. Add the basic framework for a program.

1| task main ()

2| {

3 2. Add this code

4 Add a task main() {}.
ol 1

3. Engage Motor Synchronization on the robot, with the sync mode set to “synchBC”.
The special term synchBC defines B and C as the motors to be synchronized.

1 task main()

2 {

3

4 (nSyncedMotors = synchBC ;) gnAadz mgocrode

5 Syr?dﬁ'onizaﬁon for
6 } Motors B and C, with

B set as the master.

. /
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Improved Movement synchronized Motors (cont)

Checkpoint

The program will now operate motors B and C in Synchronized mode. The order of the

letters BC in “synchBC"” does matter, because the two motors in a synchronized setup are not

completely equal. Of the pair, one of the two motors will take the lead, and the other will

play a more reactive role.

The motor B (the first letter in “synchBC”) is called the Master motor, and C (the second one)

is called the Slave motor. All commands to the motor pair, such as speed or braking

commands, are issued through the Master motor.

The Slave motor, C in this case, doesn’t receive a speed command. Instead, we give it a

ratio command. This ratio is defined as a percentage of the first motor’s position. For

moving forward, you always want the two motors to be at the same position, so we'll set the

Slave motor ratio to be 100% of the Master motor’s.

4. Set the slave motor to run at 100% of the master motor’s speed.

1| task main () ——— 4. Add this code

2 { Set the turn ratio for
the slave motor (C) to

3 be 100%. Slave motor

4 nSyncedMotors = synchBC; C will now attempt fo

; maintain exactly 100%

5 (nSyncedTurnRatlo = 100;) of the master motor B's

6 speed.

/4 ) Note that the master
motor’s speed has not
been set yet, so the slave
motor B will initially be
running at 100% of O
(i.e. stopped).

5. Set the master motor to a desired speed of 50, and let the robot run for 4 seconds.

1 task main ()

2

8

4 nSyncedMotors = synchBC;

5 nSyncedTurnRatio = 100;

6

/ motor [motorB] = 50 | 5. Add this code

8 waltlMsec (4000) ; J Set a desired speed

9 of 50 for the master
motor. Master motors

10 } are automatically PID
speed regulated.
- /
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6. Save your program as “LabyrinthSynch”.

Improved Movement synchronized Motors (cont)

View Hobob \Window Help
Mew N | P |
Open and Compile ———
Open $ample Program

vncedTurnBatio

Ctrl+-3
I L‘yncedl‘{otors = synchEC;

= 100

N

6a. Save program As...
Select File > Save As... to save your
program under a new name.

6b. Browse to an

Prink...
Print Previemw

kP

appropriate folder
Browse to or create an appropriately
named folder within your program

Savein: |3 programs v O % == folder to save your program.
[Z] Labyrinth.c
Q E} [Z) LabyrinthPID.c
My Recent
Documents
[
D
6c. Rename program
Give this program the
new name “LabyrinthSynch”.
File narne: LabyrinthSyncH ) A | Save 6d. Save
Save as type: C Files [*.ree 6 .cpp;”.nge;™ hi".ngh) 3 | Carcel Click Save.

5. Download and Run.

3 RobotC - LabyrinthSynch.c

File Edit Yiew R wWindow Hel

=y =

i Program
[#- Batkery & Po
Construcks Debugger
isplay
Matars MAT Brick

Platfarm Twpe
Mokors and Sensors Setup

2400
Refresh Rate
On

7a. Compile and Download
Click Robot > Compile and
Download Program.

#-User Defined | Download Firmware

- |

||
Clear &1l

| —

N

7b. Run the program
Click “Start” on the onscreen
Program Debug window.

/
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Improved Movement synchronized Motors (cont)

Checkpoint
The motors are now constantly updating themselves to maintain identical positions as they move.
If one motor happens to stop, the other motor will adjust, and maintain 100% of the new position!

Finally, motor synchronization is useful for far more than just going straight. Cleaning up turning
is also quite easy. As you saw when you first encountered turns, all you need to do is set the
motors to move at different speeds. To turn in place, the motors should go different speeds. For a
point turn, they should be completely opposite. The Slave motor should go -100% of the Master
motor’s speed.

8. Change the sync ratio to -100% to make the robot turn instead of moving straight.

1 task main|()

2 {

8

4 nSyncedMotors = synchBC;

5 nSyncedTurnRatio =‘ -100; } 8. Modify this code

6 Change the sync ratio

100% to -100% to make

7 motor [motorB] = 50; the motors turn in exactly
) waitlMsec (4000) ; opposite directions.

9
10 }

9. Download and Run.

<3 RobotC - LabyrinthSynch.c *
File Edit Wiew NG Window Help
Dl rload Fragram FS 9a. Compile and Download
EF F Click Robot > Compile and

Battery & Pow

C Construcks Debugger Download Progrqm.
Display
Maotars MAT Brick

Sensors

cound Platfarm Twpe 2400

4-0un Refresh Rate

Timing Mokors and Sensors Setup e = ob. R .

User Defined | Download Firmiware = Rl g e— - Run the program

Click “Start” on the onscreen

Program Debug window.

-

. /
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End of Section

most important thing is getting your robot to go straight.

N

Improved Movement synchronized Motors (cont)

Motor synchronization allows you to control your robot in a way that prioritizes motor
alignment over motor speed. This is a trade-off, but one that may be favorable when the

N

/

© Carnegie Mellon Robotics Academy / For use with LEGO® MINDSTORMS® Education NXT software and base set 9797

Improved Movement ¢ 19



